初めてのCisco IOSルータの初期セットアップ -Telnetが出来るまで-CCNA

今回は、初めてCiscoのIOSルータを設定する人のために初期セットアップからTelnetが出来るまでを書いていきます。

ネットワークのスキルを上げるためには、実機を触るってことはすごく大切です。自分で考えながらやるので理解するのが早いですし、本を読んでわからなかったことも「なるほど」と理解できたりします。自分の中でイメージが出来上がります。

ただ、いきなり実機を触るというのは、すごくハードルが高いことです。何を用意したらいいのかも大変です。最初はコンソールケーブルを用意してルータを設定する必要があるのですが、どんなケーブルを用意したらいいかもわからない。

ですので、「ネットワークの勉強を始めて実機で理解しようとしている方」、「CCNA ICND1,2を受験するために実機で勉強中の方」のために、何を揃えたらいいのかということから、実機の初期セットアップ、Telnet接続まで出来るように書いていきます。

今回利用するCiscoのルータは、安価でもっとも小さいルータのCisco892Jで設定していきます。

 

Contents

はじめに

今回は、CiscoルータにIPアドレスの設定をしてリモートのパソコンからTelnet接続するようにしていきます。

・今回の検証に必要なもの

CiscoルータにTelnetで接続するテストをするためには、以下2つです。

①初期セットアップで必要なもの

②Telnet接続で必要なもの

①初期セットアップに必要なもの

Cisco892Jの初期セットアップには、パソコンとルータをコンソール接続する必要があります。コンソール接続は、ルータに何も設定がなくても、ソフトウェアを使って設定することができます。具体的には以下のものが必要になります。

  • パソコンは、WindowsでもMacのどちらでもOK
  • USBシリアル変換ケーブル(USB<->DB-9)
  • ロールオーバケーブル(DB-9<->RJ45)

【イメージ図】

USBシリアル変換ケーブル

下の画像の右側がDB9、左側がUSBです。DB-9とは、ピンが9個あるものです。Dサブ9ピンという時もあります。

パソコンのUSBポートとロールオーバケーブルのDB-9と接続に利用します。

どれを購入したらいいの?

私のオススメは、以下の製品です。Amazonで買いました。値段は安いし、WindowsもMacも対応しています。私のパソコンで問題なく動作しています。Windows8.1、Macは、Sierraです。

USB-シリアル変換ケーブル

ロールオーバーケーブル

RJ45とDB-9のケーブルです。下の画像の左がRJ45コネクタ、右がDB-9です。
このケーブルをルータ(RJ45)とUSBシリアル変換ケーブル(DB-9)を接続に利用します。RJ45は、LANケーブルで利用されているので見たことがある方は多いでしょう。

どれを購入したらいいの?

安い製品でいいと思います。私は、Amazonで下記を選びました。

ロールオーバーケーブル

もし、ロールオーバーケーブルの配線方法を知りたい方は、こちらの記事が参考になります。

ネットワークの基礎を覚える ③ツイストペアケーブルをマスターする

②Telnet接続で必要なもの

パソコンを使ってCisco892JにTelnet接続をするためには、パソコン以外に以下のものが必要になります。

  • 【パソコンにLANポートがない場合】USB-LAN変換ケーブル(USB<->LAN)
  • UTPケーブル(RJ45<->RJ45)

どれを購入したらいいの?

こちらも安い製品でいいと思います。もし既にお持ちであれば、それを利用すればいいと思います。

USB-LAN変換ケーブル

UTPケーブルは、カテゴリー5以上だったら、なんでも大丈夫です。カテゴリーは、1〜7まであります。数字が上がるごとに品質が上がっていきます。下のケーブルは、6aです。10GbaseTX 10Gbpsまで対応したものです。今回の環境では問題なく利用できます。

UTPケーブル

【手順1】 コンソール接続する※電源ONする前に

下の図の通りにケーブルを接続します。
電源ONする前にコンソール接続する理由は、ルータが起動した時に表示されるログをターミナルソフトから見るためです。

【Cisco892J Consoleポートの画像】

これをより詳細にコンソール接続の詳細を知りたい場合は、下記の記事を参照してください。参考になると思います。

ルータへの接続方法をまとめてみる(Cisco IOS操作の基礎)

【手順2】ターミナルソフトを用意する

ターミナルソフトからコンソール接続する(Windows)

Windowsの場合は、Tera Termでコンソール接続ができます。こちらからダウンロードできます。

Tera Termを立ち上げると下記の画像が出てきます。シリアル接続をするので、シリアルにチェックを入れて、OKボタンを押します。

真っ黒な画面で[Enter]キーを押しても何も反応がないと思います。まだルータので電源がONになっていないからです。

※シリアルのところに何も表示されていない場合。①か②をご確認ください。

①USBポートにUSBシリアル変換ケーブルが接続されていない

②パソコンがUSB-シリアルケーブルを認識していません。デバイスドライバーのインストールが必要になります。デバイスドライバーは、お使いのUSBシリアル変換ケーブルにCD-ROMで付属しているか、メーカーのWebサイトにあったりします。

 

ターミナルソフトからコンソール接続する(Mac)

Macの場合は、標準のターミナルでもできますが、私はiTerm2を使っています。使い勝手がいいからです。


ダウンロードは、こちらから

USB-シリアル変換ケーブルのデバイスドライバーをインストールして、下記のコマンドを実行します。まだルータの電源がONになっていないので、何も表示されません。

screen /dev/tty.usbserial
 ※このコマンドが実行できない場合、①か②をご確認ください。①USBシリアル変換ケーブルをパソコンに接続していない。

②デバイスドライバーがインストールされていない。デバイスドライバーをインストールしてください。デバイスドライバーは、お使いのUSBシリアル変換ケーブルにCD-ROMで付属しているか、メーカーのWebサイトにあったりします。

③デバイスドライバーのファイルが違うかもしれません。 ls /dev/tty.* でusbserialに似た名前がないか探してみてください。もしあったら、その名前で実行してください。

 

【手順3】ルータの電源を入れる

ルータの電源をONにします。

そうすると、ターミナルソフトからルータが起動してきたログが表示されてきます。これは、POST (Power-On Self Test)といいます。電源投入時にルータが機器にエラーはないか確認しているのです。

System Bootstrap, Version 12.4(22r)YB5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2009 by cisco Systems, Inc.C890 platform with 786432 Kbytes of main memoryUpgrade ROMMON initialized

 

 

そうすると、Would you like to enter the initial configuration dialog?[yes/no]:が表示されます。初期セットアップを対話形式でしますか?というメッセージです。今回は、「No」とします。コマンドで設定をしていくためです。

— System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: no ← 今回は No とする 

 

そうすると、「Router > 」と表示されます。その前にいろんなログが表示されますが、気にしないで大丈夫です。これはまだルータのポートに何もつながっていないので、”ポートが落ちました”というメッセージです。

—*Sep 27 20:44:36.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet6, changed state to down
*Sep 27 20:44:36.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7, changed state to down
Router>

【手順4】ルータに設定する

これからいよいよルータに設定をしていきます。

まず、設定に入る前に理解を深めるためにモードの説明をします。Ciscoルータにはいろんなモードがあります。一部のコマンドしか許可しないモード、全部許可したモード、設定変更したモードなどあります。

今どのモードなのかは、ホスト名の右に表示されている文字でわかります。

  • >  ユーザEXECモード。一部のコマンドだけ許可
  • # 特権EXECモード。全部許可
  • (config***) コンフィグレーションモード。設定するときにモード。*** としたのは、様々なコンフィグレーションモードがあるため。

現在は、「Router > 」なので、ユーザEXECモードです。一部のコマンドしか実行できません。

【手順4-1】enableをして特権EXECモードに入る

「enable」と入力してEnterキーを押します。そうすると、”Router”の右に表示されている文字が > から #に変更されます。#が特権EXECモードです。コマンドを全部許可されたモードです。

Router>
Router>enable
Router#

【手順4-2】ホスト名を設定する

ホスト名は、装置の名前です。現在のホスト名は、「Router」になっています。これを好きな名前に変えてみます。

現在のホスト名の設定を確認する

設定をする前に、今のどのような設定になっているか確認する必要があります。「show running-config」コマンドで、現在の設定内容を確認できます。running-configは、動作中のコンフィグレーションです。
–More–が表示されたら、[space]キーを押し続けて全部表示させます。

ホスト名の設定する行は、hostname Router のところです。現在は、Routerと設定されています。

Router#show running-config ←コマンド
Building configuration…Current configuration : 1396 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router ←ホスト名の設定

ホスト名を設定する

configure terminal」 と入力してコンフィグレーションモードに入ります。コンフィグレーションモードは、設定変更するモードです。ホスト名の右の文字が (config) となります。文字入力の途中で[tab]キーを押すとコマンドを補完してくれるので便利です。

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

「hostname <ホスト名>」を入力してホスト名を変更します。お好きなホスト名にしてください。
下の例では、ホスト名をrunsurunet01に変更しています。変更をしたら、すぐに名前が変更されます。

Router(config)#hostname runsurunet01
runsurunet01(config)#
ホスト名がすぐに変わる

※間違ってしまった場合

頭にnoを入れて消すことができます。

runsurunet01(config)#no hostname

「end」と入力して特権EXECモードに戻ります。なお、「exit」でも戻ります。この2つのコマンドの違いを覚えておくと便利です。

  • end 特権EXECモードに戻る
  • exit 一つ前の階層に戻る。コンフィグレーションモードでexitをすると、一つ前の特権EXECモードに戻る。
runsurunet01(config)#end
runsurunet01#

 

変更したホスト名の設定を確認する

設定変更した後は、ちゃんとrunning-configが変更されたか確認することが大切です。

show running-config」コマンドで、設定内容を確認します。

ホスト名の設定する行は、hostname runsurunet01 のところです。設定が変わっていることがわかります。

runsurunet01#show running-config ←コマンド
Building configuration…Current configuration : 1396 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router ←ホスト名の設定

 

【手順4-3】インタフェースにIPアドレスを設定する。

パソコンからルータにIPの通信をするために、ルータのインタフェースにIPアドレスを設定します。今回ルータに設定するインタフェースはGigabitEthernet0、IPアドレス:192.168.0.2 サブネットマスク:255.255.255.0に設定をします。

インタフェースのリンク状態を確認する

GigabitEthernet0のリンク状態を確認します。リンク状態の確認とは、そのインタフェースが利用できるのか、ケーブルが接続されているのかということです。コマンドは、「show ip interface brief」です。

画面を見ると Status:administratively down、Protocol:downになっています。これは利用できない状態なので設定が必要です。

インタフェースの状態には、主に以下の種類があります。左がStatus/右がProtocolの欄の表示です。

  • administratively down/down : インタフェースが閉じている。shutdownが設定されている
  • down/down : インタフェースは空いているが、Linkが上がっていない。お互いの装置にケーブルが接続されていない
  • up/up :インタフェースは空いていて、ケーブルが接続されている。利用できる状態。

インタフェースの設定を確認する

GigabitEthernet0のインタフェースの設定を確認するには、「show running-config interface gigabitethernet0」をします。

runsurunet01#show running-config interface gigabitEthernet0
Building configuration…Current configuration : 84 bytes
!
interface GigabitEthernet0
no ip address ← IPアドレスが設定されていない
shutdown  ←ポートが閉じている。利用できない状態
duplex auto ←duplexが自動
speed auto  ←速度が自動
end ← GigabitEthernet0の設定はここまでということ。

duplex autospeed autoは、オートネゴシエーションになる設定です。

オートネゴシエーションは、自動で速度を決める設定です。ケーブルがつながる両方の装置でオートネゴシエーションにしていれば、勝手にお互いの速度を決めてくれてリンクがupします。パソコン側は、オートネゴシエーションになってますので、ルータ側もオートネゴシエーションにしておきます。詳しい記事は、普段意識しないけど使っているオートネゴシエーション

また、「show running-config」でも設定を確認できますが、ルータ全体の設定が表示されてしまうため、探す時間がかかります。show running-config interface で絞れば、gigabitethernet0の設定だけ表示されるので便利です。

インタフェースを設定する

configure terminal」 と入力してコンフィグレーションモードに入ります。

その次に「interace gigabitethenet0」と入力します。 表示名が(config-if)となります。これをインタフェースコンフィグレーションモードといいます。

runsurunet01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
runsurunet01(config)#interface gigabitethernet0
runsurunet01(config-if)#

 

続いてIPアドレスの設定とshutdownを消します。設定を消すときは、頭にnoを入れます。

runsurunet01(config-if)#ip address 192.168.0.2 255.255.255.0 ←IPアドレスの設定
runsurunet01(config-if)#no shutdown ← 頭にno を入れて shutdownを消す
runsurunet01(config-if)#
runsurunet01(config-if)#end ←特権EXECモード
runsurunet01#
↓設定変更したのでログが表示される。
*Sep 28 21:24:51.815: %LINK-5-CHANGED: Interface GigabitEthernet0, changed state to reset
*Sep 28 21:24:53.019: %SYS-5-CONFIG_I: Configured from console by console
*Sep 28 21:24:58.227: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state to down

※間違ってしまった場合
頭にnoを入れて消すことができます。no shutdownは、shutdownにする。

runsurunet01(config-if)#ip address
runsurunet01(config-if)#shutdown
runsurunet01(config-if)#
runsurunet01(config-if)#end ←特権EXECモード
runsurunet01#

変更後のインタフェースの状態を確認する

GigabitEthernet0の状態を確認します。コマンドは、「show ip interface brief」です。

画面を見ると down downになっています。no shutdownをしたのでadministratively downからdown downに変わりました。しかし、LANケーブルを接続していないため、upにはなりません。ケーブルはこの後接続します。IPアドレスも設定した内容が表示されます。

変更後のインタフェースの設定を確認する

GigabitEthernet0のインタフェースの設定を確認するには、「show running-config interface gigabitethernet0」をします。

先ほど設定した内容が表示されていることを確認します。

runsurunet01#show running-config interface gigabitethernet0Building configuration…

Current configuration : 97 bytes
!
interface GigabitEthernet0
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
end

【手順4-4】LANケーブルを接続する

パソコンのLANポートとルータのGigabitEthernet0ポートケーブルを接続します。

【GigabitEthernet0のポート】※WAN GE0となっている。

インタフェースの状態を確認する

GigabitEthernet0の状態を確認します。コマンドは、「show ip interface brief」です。

うまくいけば up upとなります。LinkUp状態です。

down downの場合は、ケーブルが壊れているか、パソコンのLANポートが壊れている可能性が高いです。もし、変わりのケーブルがあるのでしたら試してみてください。

【手順4-5】※パソコン側のIPアドレスを設定する

パソコン側のLANポートにIPアドレス 192.168.0.1 255.255.255.0を設定します。

Windowsの場合

コントロールパネル > ネットワークとインターネット > ネットワークの状態とタスクの表示をクリック

左にある「アダプターの設定の変更」をクリックします。

下記画像のように①識別されていないネットワークを選択して右クリックをして、②プロパティをクリックします。

 

インターネットプロトコルバージョン4 (TCP/IPv4)を選択してプロパティをクリックします。

IPアドレス 192.168.0.1 サブネットマスク 255.255.255.0に設定してOKをクリックします。

Macの場合

システム環境設定 > ネットワークの順番に開きます。

①自己割り当てIP となっているLANポートのアダプタを選択
②IPv4の設定を手入力に変更してIPアドレス 192.168.0.1 サブネットマスク 255.255.255.0

右下の適用を押します。

【手順4-6】pingで疎通試験をする

ルータからパソコンにpingをしてみます。pingは、IPの通信がうまくいくか試験するときに利用します。パソコンのIPアドレスは192.168.0.1です。ルータから「ping 192.168.0.1」とすれば、パソコン↔︎ルータの通信を確認できます。

!!!!! となれば成功です。

ここの表示が ….  となっていると、pingが失敗です。IPアドレス、サブネットマスクの設定が間違っている、インタフェースがupしていないなど間違いがありますので、もう1度内容を確認する必要があります。

【手順4-7】Telnetの設定する

telnetの設定をしていきます。telnetをするためには、ルータに仮想ポート(VTY)を作成する必要があります。VTYとは、ルータの中にある論理ポートのことです。目に見えるLANポート(gigabitethernet0など)ではなく設定で作られたポートです。

今回は、VTYポートを0〜4で設定します。5個 ポートを作るということです。5個telnetが出来るようにするわけです。

Telnetの設定を確認する

telnetの設定を確認するには、「show running-config」をします。telnetの設定は、下の方です。[space]キーを押して進めてください。line vty 0 4 のところがtelnetの設定です。追加で設定が必要です。

line vty 0 4
login ←パスワードの設定をしないとtelnetできないという設定
transport input none ←接続を拒否
!

Telnetを設定する

configure terminal」 と入力してコンフィグレーションモードに入ります。

その次に「line vty 0 4」と入力します。0 4という数字は、0番から4番のポートを作りますということです。

表示名が(config-line)となります。これをラインコンフィグレーションモードといいます。

runsurunet01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
runsurunet01(config)#line vty 0 4
runsurunet01(config-line)#

続いてコンフィグを入れます。

runsurunet01(config-line)#password cisco ←telnetでログインするパスワードを「cisco」に設定
runsurunet01(config-line)#transport input telnet ←telnetを許可

runsurunet01(config-line)#end
runsurunet01#

※間違ってしまった場合
頭にnoを入れて消すことができます。transport inputを消すときは、no transport input です。 

runsurunet01(config-line)#no password
runsurunet01(config-line)#no transport input
runsurunet01(config-line)#end
runsurunet01#

変更後のTelnetの設定を確認する

「show running-config 」で設定を確認します。先ほど設定した内容が表示されていることを確認します。

line vty 0 4
password cisco
login
transport input telnet
!

【手順4-8】Telnet接続を試してみる

これでTelnet接続できるようになりました。さっそくパソコンから試してみましょう。

Windowsの場合

Teratermを開き、ホスト:192.168.0.2(ルータのIPアドレス)、サービスをTelnetを選択してOKをクリックします。最初は、ssh担っているのでご注意を。

Macの場合

itermを開き、「telnet 192.168.0.2」(ルータのIPアドレス)と入力して[Enter]キーを押します。

Telnetの実行

Telnet接続に成功すると、下記の通りpasswordを聞かれるようになります。passwordは、「cisco」です。telnet接続のところで設定したものです。password cisco ですね。

as:~ as$ telnet 192.168.0.2Trying 192.168.0.2…
Connected to 192.168.0.2.
Escape character is ‘^]’.
User Access VerificationPassword:←passwordを入力する

 

パスワード入力した後、ユーザEXECモードになります。これでは一部のコマンドしか入れられないため、「enable」をして特権EXECモードに入ります。

runsurunet01>
runsurunet01>enable

 

しかし、% No password Set が表示されて先に進めないと思います。「password設定したじゃないか!」という声が聞こえてくるのがよくわかります。

 

runsurunet01>ena
% No password set

先ほど設定したパスワードは、line vty 0 4のパスワード、つまりTelnet用のパスワードです。

特権EXECモードに入る時のパスワードは別です。これには、イネーブルパスワードを設定する必要があります。

【手順4-9】イネーブルパスワードを設定する

イネーブルパスワードを設定する

configure terminal」 と入力してコンフィグレーションモードに入ります。続いてイネーブルパスワードを設定します。

enable password <パスワード>

runsurunet01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
runsurunet01(config)#enable password ccna ←イネーブルパスワードを「ccna」に設定
runsurunet01(config)#end

※間違ってしまった場合

頭にnoを入れて消すことができます。

runsurunet01(config-line)#no enable password

変更後のイネーブルパスワードの設定を確認する

「show running-config 」で設定を確認します。先ほど設定した内容が表示されていることを確認します。

runsurunet01#show running-configBuilding configuration…

Current configuration : 1516 bytes
!
! Last configuration change at 22:50:22 UTC Thu Sep 28 2017
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname runsurunet01
!
boot-start-marker
boot-end-marker
!
!
enable password ccna ← イネーブルパスワードの設定

!

【手順4-10】再びTelnet接続をする

今度は、telnet接続をしてルータにログインした後、enableと入力するとパスワードが聞かれます。先ほど設定したパスワード「ccna」を入力します。

そうすると、ホスト名の右が#となって特権EXECモードになります。これで成功です。

as:~ as$ telnet 192.168.0.2Trying 192.168.0.2…
Connected to 192.168.0.2.
Escape character is ‘^]’.
User Access VerificationPassword: ←telnet 接続のpassword 「cisco」
runsurunet01>
runsurunet01>ena
Password:←イネーブルパスワードの「ccna」
runsurunet01#

 

【手順4-11】設定の保存

最後に設定の保存をします。

少しだけCiscoのコンフィグレーションファイルの話をします。結構重要です。

Cisco IOSには、設定した内容を管理するコンフィグレーションファイル(設定ファイル)があります。コンフィグレーションファイルは、running-configとstartup-configと2つあります。

設定しているときは、running-configに書き込んでいます。runningなので動作中のコンフィグということです。このrunning-configは、再起動や電源がOFFになると消えてしまいます。

startup-configは、再起動や電源がONしたときに読み込まれるコンフィグです。startupですからまさに最初って感じですよね。

ですので、そうならないためにも設定の保存をします。running-configの内容をstartup-configにコピーします。

ドラゴンクエストやゲームをやったことがある方ならイメージしやすいでしょう。設定の保存は、ゲームのセーブと同じです。セーブしないとせっかく進めたゲームもやり直しになりますからね。

コマンドは、「copy running-config startup-config」です。OKが出れば完了です。

runsurunet01#copy running-config startup-config
Destination filename [startup-config]?←[Enter]キーを押す
Building configuration…
[OK]
runsurunet01#

おわりに

お疲れさまでした。ここまでやるのは結構大変だと思います。何も設定されていない実機を触ったことによって、スキルはすごく上がったと思います。Telnet接続が出来るようになったら、リモートからも設定することができます。色々試してスキルアップを目指しましょう。

当サイトにCisco IOS操作の記事をいくつか書いております。スキルアップには役立つのでぜひご覧ください。

Cisco IOS操作の基礎

 

コメントを残す

コメントを投稿するにはログインしてください。